CVE-2018-1000168: Denial of Service, nghttp2 dependency
All versions of 9.x and later are vulnerable and the severity is HIGH. Under certain conditions, a malicious client can trigger an uninitialized read (and a subsequent segfault) by sending a malformed ALTSVC frame. This has been addressed through an by updating nghttp2. For further detail: https://nghttp2.org/blog/2018/04/12/nghttp2-v1-31-1/.
All versions of Node.js 6.x (LTS "Boron") are NOT vulnerable
Versions of Node.js 8.4.x and higher (LTS "Carbon") are vulnerable
All versions of Node.js 9.x are vulnerable
All versions of Node.js 10.x (Current) are vulnerable
Other sources
If ALTSVC frame is received by libnghttp2 and it is larger than it can accept, the pointer field which points to ALTSVC frame payload is left NULL. Later libnghttp2 attempts to access another field through the pointer, and gets segmentation fault. The largest frame size libnghttp2 accept is by default 16384 bytes.
Receiving ALTSVC frame is disabled by default. Application has to enable it explicitly by calling nghttp2optionsetbuiltinrecvextensiontype(opt, NGHTTP2ALTSVC).
Transmission of ALTSVC is always enabled, and it does not cause this vulnerability. ALTSVC frame is expected to be sent by server, and received by client as defined in RFC 7838.
Affected versions: nghttp2 >= 1.10.0 and nghttp2 <= v1.31.0
— Red Hat
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/nghttp2to a version that resolves this vulnerability.Fixed in 1.31.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 10.4.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 8.11.3 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 9.11.2 - Upgrade
Upgrade
nghttp2to a version that resolves this vulnerability.Fixed in 1.31.1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is CVE-2018-1000168?
CVE-2018-1000168 is a vulnerability in nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 that contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling.
How severe is CVE-2018-1000168?
CVE-2018-1000168 has a severity rating of 7.5 (high).
Which software versions are affected by CVE-2018-1000168?
nghttp2 version >= 1.10.0 and <= v1.31.0, Node.js versions 6.0.0 to 6.8.1, 8.4.0 to 8.17.0, and 9.0.0 to 9.11.2, as well as Debian Linux version 9.0 are affected by CVE-2018-1000168.
How can the CVE-2018-1000168 vulnerability be exploited?
The CVE-2018-1000168 vulnerability can be exploited through a network client.
How can I fix CVE-2018-1000168?
To fix CVE-2018-1000168, you should update your nghttp2 package to version 1.31.1.