CVE-2018-1000215: High severity Cjson Project Cjson vulnerability
Dave Gamble cJSON version 1.7.6 and earlier contains a CWE-772 vulnerability in cJSON library that can result in Denial of Service
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Dave Gamble cJSONto a version that resolves this vulnerability.Fixed in 1.7.7
Event History
Frequently Asked Questions
What is CVE-2018-1000215?
CVE-2018-1000215 is a vulnerability in the cJSON library that can result in Denial of Service (DoS) due to a memory leak issue.
How does CVE-2018-1000215 impact my system?
CVE-2018-1000215 can be exploited by an attacker to force a leak of memory, resulting in a Denial of Service (DoS) condition if the system is in low memory.
What software is affected by CVE-2018-1000215?
The cJSON library versions 1.7.6 and earlier, developed by Cjson Project, are affected by CVE-2018-1000215.
What is the severity of CVE-2018-1000215?
CVE-2018-1000215 has a severity rating of 7.5 (High).
Is there a fix available for CVE-2018-1000215?
Yes, upgrading to a version later than 1.7.6 of the cJSON library resolves the vulnerability.