CVE-2018-10188: phpMyAdmin CSRF vulnerability allowing arbitrary SQL execution
phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/dboperations.js, js/tbloperations.js, libraries/classes/Operations.php, and sql.php.
Other sources
phpMyAdmin CSRF vulnerability allowing arbitrary SQL execution
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.8.0.1 - Upgrade
Upgrade
alpine/phpmyadminto a version that resolves this vulnerability.Fixed in 4.8.0-r1
Event History
Frequently Asked Questions
What is CVE-2018-10188?
CVE-2018-10188 is a vulnerability in phpMyAdmin version 4.8.0 that allows an attacker to execute arbitrary SQL statements.
How severe is CVE-2018-10188?
CVE-2018-10188 has a severity score of 8.8, which is considered high.
How can an attacker exploit CVE-2018-10188?
An attacker can exploit CVE-2018-10188 by performing a Cross-Site Request Forgery (CSRF) attack to execute arbitrary SQL statements.
Which software versions are affected by CVE-2018-10188?
phpMyAdmin version 4.8.0 is affected by CVE-2018-10188.
Are there any known exploits for CVE-2018-10188?
Yes, there are known exploits for CVE-2018-10188 available on exploit-db.com.