CVE-2018-1065: Null Pointer Dereference

Published Feb 22, 2018
·
Updated

The Linux kernel at version 4.15.0-rc9 is vulnerable to a NULL pointer dereference ip6tables.c:ip6tdotable() leading to a crash. This vulnerability is only present under certain malformed iptables rulesets.

Inserting malformed rules its a privileged operation as root or a user with CAPNETRAW,CAPNETADMIN capabilities ( see man setcap(8) ).

As this requires advanced privileges Red Hat Product Security has rated this flaw as moderate.

Additional References:

Netdev list: http://lists.openwall.net/netdev/2018/01/27/46

A suggested upstream patch: http://patchwork.ozlabs.org/patch/870355/

An upstream patch: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=57ebd808a97d7

Other sources

The netfilter subsystem in the Linux kernel through 4.15.7 mishandles the case of a rule blob that contains a jump but lacks a user-defined chain, which allows local users to cause a denial of service (NULL pointer dereference) by leveraging the CAPNETRAW or CAPNETADMIN capability, related to arptdotable in net/ipv4/netfilter/arptables.c, iptdotable in net/ipv4/netfilter/iptables.c, and ip6tdotable in net/ipv6/netfilter/ip6tables.c.

— Ubuntu

Affected Software

2 affected componentsFixes available
Linux Linux kernel<=4.15.7
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1

Event History

Feb 22, 2018
Data Sourced
via Red Hat·03:32 AM
DescriptionSeverityAffected Software
Mar 2, 2018
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·08:00 AM
Data Sourced
via MITRE·08:00 AM
DescriptionWeakness
Data Sourced
via NVD·08:29 AM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2018-1065?

CVE-2018-1065 is a vulnerability in the Linux kernel netfilter subsystem that can cause a denial of service.

2

How severe is CVE-2018-1065?

CVE-2018-1065 has a severity level of medium.

3

How does CVE-2018-1065 affect Linux?

CVE-2018-1065 affects the Linux kernel through version 4.15.7.

4

How can the CVE-2018-1065 vulnerability be fixed?

To fix CVE-2018-1065, update the Linux kernel to version 4.16 or above.

5

Where can I find more information about CVE-2018-1065?

You can find more information about CVE-2018-1065 at the following references: [Link 1](http://lists.openwall.net/netdev/2018/01/27/46), [Link 2](http://patchwork.ozlabs.org/patch/870355/), [Link 3](https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=57ebd808a97d7)

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203