CVE-2018-10853: High severity Canonical Ubuntu Linux vulnerability
A flaw was found in the way Linux kernel KVM hypervisor before 4.18 emulated instructions such as sgdt/sidt/fxsave/fxrstor. It did not check current privilege(CPL) level while emulating unprivileged instructions. An unprivileged guest user/process could use this flaw to potentially escalate privileges inside guest.
Other sources
A flaw was found in the way Linux kernel KVM hypervisor emulated instructions such as sgdt/sidt/fxsave/fxrstor. It did not check current privilege(CPL) level while emulating unprivileged instructions.
An unprivileged guest user/process could use this flaw to potentially escalate privileges inside guest.
Upstream patch: --------------- -> https://git.kernel.org/linus/3c9fa24ca7c9c47605672916491f79e8ccacb9e6
Issue introduced in: (kernel v4.10+) -------------------- -> https://git.kernel.org/linus/129a72a0d3c8e139a04512325384fe5ac119e74
Reference: ---------- -> http://www.openwall.com/lists/oss-security/2018/09/02/1
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:3.10.0-1062.rt56.1022.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-1062.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-693.62.1.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-862.46.1.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-957.43.1.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 4.18 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1 - Upgrade
Upgrade
Linux kernel KVM hypervisorto a version that resolves this vulnerability.Fixed in 4.18
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2018-10853?
CVE-2018-10853 has a medium severity rating due to its potential for privilege escalation.
How do I fix CVE-2018-10853?
To fix CVE-2018-10853, upgrade to kernel version 4.18 or later as specified in the security advisories from the affected distributions.
Which systems are affected by CVE-2018-10853?
CVE-2018-10853 affects various versions of the Linux kernel, particularly those prior to 4.18, including specific versions in Red Hat, Ubuntu, and Debian.
What impact does CVE-2018-10853 have on a system?
CVE-2018-10853 could allow an unprivileged guest user or process to exploit the vulnerability for privilege escalation on the host.
Is CVE-2018-10853 a guest-to-host attack vector?
Yes, CVE-2018-10853 allows a guest user to potentially escalate privileges to the host system.