CVE-2018-1093: Medium severity Linux Linux kernel vulnerability

Published Mar 27, 2018
·
Updated

Last updated 4 July 2026

Other sources

The ext4validblockbitmap function in fs/ext4/balloc.c in the Linux kernel through 4.15.15 allows attackers to cause a denial of service (out-of-bounds read and system crash) via a crafted ext4 image because balloc.c and ialloc.c do not validate bitmap block numbers.

— Launchpad

The Linux kernel is vulnerable to an out-of-bounds read in ext4/balloc.c:ext4validblockbitmap() function. An attacker could trick a legitimate user or a privileged attacker could exploit this by mounting a crafted ext4 image to cause a crash.

References:

https://bugzilla.kernel.org/showbug.cgi?id=199181

http://seclists.org/oss-sec/2018/q1/284

An upstream patch:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=7dac4a1726a9c

— Red Hat

Affected Software

2 affected componentsFixes available
Linux Linux kernel<=4.15.15
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1
  2. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Fixed in 4.15.15
  3. Compensating control

    Mitigate by avoiding mounting untrusted/crafted ext4 images; restrict who can supply or mount ext4 filesystem images to reduce exposure to the ext4_valid_block_bitmap() out-of-bounds read crash condition.

Event History

Mar 27, 2018
Data Sourced
via Red Hat·12:59 AM
DescriptionSeverityAffected Software
Apr 2, 2018
CVE Published
via MITRE·03:00 AM
Data Sourced
via MITRE·03:00 AM
DescriptionWeakness
Data Sourced
via NVD·03:29 AM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID?

The vulnerability ID is CVE-2018-1093.

2

What is the severity of CVE-2018-1093?

The severity of CVE-2018-1093 is low.

3

What is the affected software?

The affected software includes the Linux kernel versions 4.15.15 and below.

4

How can attackers exploit CVE-2018-1093?

Attackers can exploit CVE-2018-1093 by crafting a malicious ext4 image that causes an out-of-bounds read and system crash.

5

Are there any references for more information about CVE-2018-1093?

Yes, you can find more information about CVE-2018-1093 at the following references: - http://openwall.com/lists/oss-security/2018/03/29/1 - https://bugzilla.kernel.org/show_bug.cgi?id=199181 - https://bugzilla.redhat.com/show_bug.cgi?id=1560782

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203