CVE-2018-11385: Session Fixation Issue for Guard Authentication
An issue was discovered in the Security component in Symfony 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11. A session fixation vulnerability within the "Guard" login feature may allow an attacker to impersonate a victim towards the web application if the session id value was previously known to the attacker.
Other sources
CVE-2018-11385: Session Fixation Issue for Guard Authentication
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/symfonyto a version that resolves this vulnerability.Fixed in 3.4.22+dfsg-2+deb10u1Fixed in 3.4.22+dfsg-2+deb10u2Fixed in 4.4.19+dfsg-2+deb11u3Fixed in 5.4.23+dfsg-1Fixed in 5.4.29+dfsg-1Fixed in 5.4.30+dfsg-1 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
composer/symfony/security-guardto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
composer/symfony/security-guardto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
composer/symfony/security-guardto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
composer/symfony/security-guardto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 4.0.11
Event History
Frequently Asked Questions
What is CVE-2018-11385?
CVE-2018-11385 is a session fixation issue in the Security component in Symfony which allows an attacker to impersonate a victim.
What is the severity of CVE-2018-11385?
CVE-2018-11385 has a severity value of 8.1 (High).
Which versions of Symfony are affected by CVE-2018-11385?
Symfony versions 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11 are affected by CVE-2018-11385.
How can I fix the session fixation issue in Symfony?
To fix the session fixation issue in Symfony, you should upgrade to the latest patched version of Symfony in the affected minor versions (2.7.x, 2.8.x, 3.3.x, 3.4.x, or 4.0.x).
Where can I find more information about CVE-2018-11385?
You can find more information about CVE-2018-11385 on the Symfony website (https://symfony.com/cve-2018-11385) and the NIST NVD (https://nvd.nist.gov/vuln/detail/CVE-2018-11385).