CVE-2018-11406: CSRF Token Fixation
An issue was discovered in the Security component in Symfony 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11. By default, a user's session is invalidated when the user is logged out. This behavior can be disabled through the invalidatesession option. In this case, CSRF tokens were not erased during logout which allowed for CSRF token fixation.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/symfonyto a version that resolves this vulnerability.Fixed in 3.4.22+dfsg-2+deb10u1Fixed in 3.4.22+dfsg-2+deb10u2Fixed in 4.4.19+dfsg-2+deb11u3Fixed in 5.4.23+dfsg-1Fixed in 5.4.29+dfsg-1Fixed in 5.4.30+dfsg-1 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
composer/symfony/security-httpto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
composer/symfony/security-bundleto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
composer/symfony/security-bundleto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
composer/symfony/security-bundleto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
composer/symfony/security-bundleto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
composer/symfony/security-bundleto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
composer/symfony/security-csrfto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
composer/symfony/security-csrfto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
composer/symfony/security-csrfto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
composer/symfony/security-csrfto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
composer/symfony/security-csrfto a version that resolves this vulnerability.Fixed in 4.0.11 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 2.7.48 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 2.8.41 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 3.3.17 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 3.4.11 - Upgrade
Upgrade
Symfony Security componentto a version that resolves this vulnerability.Fixed in 4.0.11 - Configuration
Disable the behavior through the invalidate_session option.
Symfony Security component invalidate_session
Event History
Frequently Asked Questions
What is the severity of CVE-2018-11406?
CVE-2018-11406 is a medium severity vulnerability affecting multiple versions of Symfony.
How do I fix CVE-2018-11406?
To fix CVE-2018-11406, upgrade Symfony to version 2.7.48, 2.8.41, 3.3.17, 3.4.11, or 4.0.11.
Which Symfony versions are affected by CVE-2018-11406?
CVE-2018-11406 affects Symfony versions prior to 2.7.48, 2.8.41, 3.3.17, 3.4.11, and 4.0.11.
What components of Symfony are impacted by CVE-2018-11406?
CVE-2018-11406 impacts the Security component of Symfony.
Is CVE-2018-11406 exploitable?
Yes, CVE-2018-11406 can be exploited to bypass session invalidation during user logout.