CVE-2018-12613: phpMyAdmin Improper Authentication
An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.8.2 - Upgrade
Upgrade
alpine/phpmyadminto a version that resolves this vulnerability.Fixed in 4.8.2-r0
Event History
Frequently Asked Questions
What is CVE-2018-12613?
CVE-2018-12613 is a vulnerability in phpMyAdmin version 4.8.x before 4.8.2 that allows an attacker to include and potentially execute files on the server.
How does CVE-2018-12613 work?
CVE-2018-12613 exploits an improper test for whitelisted pages in phpMyAdmin, allowing an attacker to redirect and load arbitrary files on the server.
What is the severity of CVE-2018-12613?
CVE-2018-12613 has a severity rating of 8.8 (high).
How can I fix CVE-2018-12613?
To fix CVE-2018-12613, upgrade to phpMyAdmin version 4.8.2 or later.
Where can I find more information about CVE-2018-12613?
You can find more information about CVE-2018-12613 at the following references: [1] [2] [3]