CVE-2018-14678: High severity Linux Linux kernel vulnerability
An issue was discovered in the Linux kernel through 4.17.11, as used in Xen through 4.11.x. The xenfailsafecallback entry point in arch/x86/entry/entry64.S does not properly maintain RBX, which allows local users to cause a denial of service (uninitialized memory usage and system crash). Within Xen, 64-bit x86 PV Linux guest OS users can trigger a guest OS crash or possibly gain privileges.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1Fixed in 7.2.13-1
Event History
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2018-14678.
What is the affected software for this vulnerability?
The affected software for this vulnerability includes the Linux kernel versions through 4.17.11, as used in Xen through 4.11.x.
What is the impact of this vulnerability?
This vulnerability allows local users to cause a denial of service (uninitialized memory usage and system crash).
How can I fix this vulnerability?
To fix this vulnerability, update your Linux kernel to version 4.18 or higher.
Where can I find more information about this vulnerability?
You can find more information about this vulnerability at the following references: [Xen Security Advisory 274](https://xenbits.xen.org/xsa/advisory-274.html), [SecurityFocus BID 104924](http://www.securityfocus.com/bid/104924), [SecurityTracker ID 1041397](http://www.securitytracker.com/id/1041397).