CVE-2018-15470: Medium severity XEN Xen vulnerability
An issue was discovered in Xen through 4.11.x. The logic in oxenstored for handling writes depended on the order of evaluation of expressions making up a tuple. As indicated in section 7.7.3 "Operations on data structures" of the OCaml manual, the order of evaluation of subexpressions is not specified. In practice, different implementations behave differently. Thus, oxenstored may not enforce the configured quota-maxentity. This allows a malicious or buggy guest to write as many xenstore entries as it wishes, causing unbounded memory usage in oxenstored. This can lead to a system-wide DoS.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/xento a version that resolves this vulnerability.Fixed in 4.17.5+72-g01140da4e8-1Fixed in 4.17.7-0+deb12u1Fixed in 4.20.3+127-gc42374a105-0+deb13u1Fixed in 4.20.4+39-gf1e1321c87-0+deb13u1Fixed in 4.20.4+39-gf1e1321c87-1
Event History
Frequently Asked Questions
What is the severity of CVE-2018-15470?
CVE-2018-15470 has been rated as a medium to high severity vulnerability.
How do I fix CVE-2018-15470?
To fix CVE-2018-15470, upgrade Xen to version 4.11.1 or later.
What systems are affected by CVE-2018-15470?
CVE-2018-15470 affects Xen versions up to and including 4.11.0.
What kind of vulnerability is CVE-2018-15470?
CVE-2018-15470 is a logic issue in the oxenstored component of Xen.
Is there a workaround for CVE-2018-15470?
There is no known workaround for CVE-2018-15470, so applying the patch is essential.