CVE-2018-15910: Incorrect Type Cast

Published Aug 21, 2018
·
Updated

In Artifex Ghostscript before 9.24, attackers able to supply crafted PostScript files could use a type confusion in the LockDistillerParams parameter to crash the interpreter or execute code.

Other sources

It was discovered that the type of the LockDistillerParams parameter is not properly verified. A specially crafted PostScript document could possibly exploit this to crash ghostscript or, possibly, execute arbitrary code in the context of the ghostscript process.

— Red Hat

Affected Software

36 affected componentsFixes available
redhat/ghostscript<9.24
9.24
debian/ghostscript
9.53.3~dfsg-7+deb11u79.53.3~dfsg-7+deb11u910.0.0~dfsg-11+deb12u610.04.0~dfsg-2
Debian Debian Linux=8.0
Debian Debian Linux=9.0
Canonical Ubuntu Linux=14.04
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=18.04
Artifex Ghostscript<9.24
redhat Enterprise Linux Desktop=7.0
redhat Enterprise Linux Server=7.0
redhat Enterprise Linux Server Eus=7.5
redhat Enterprise Linux Workstation=7.0
Artifex Gpl Ghostscript<9.26
PulseSecure Pulse Connect Secure>=8.2r1.0<8.2r12.1
PulseSecure Pulse Connect Secure>=8.3r1<8.3r7.1
PulseSecure Pulse Connect Secure>=9.0r1<9.0r3.4
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0
alpine/ghostscript<9.24-r0
9.24-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/ghostscript to a version that resolves this vulnerability.

    Fixed in 9.24
  2. Upgrade

    Upgrade debian/ghostscript to a version that resolves this vulnerability.

    Fixed in 9.53.3~dfsg-7+deb11u7Fixed in 9.53.3~dfsg-7+deb11u9Fixed in 10.0.0~dfsg-11+deb12u6Fixed in 10.04.0~dfsg-2
  3. Upgrade

    Upgrade alpine/ghostscript to a version that resolves this vulnerability.

    Fixed in 9.24-r0
  4. Upgrade

    Upgrade Artifex Ghostscript to a version that resolves this vulnerability.

    Fixed in 9.24

Event History

Aug 27, 2018
CVE Published
via MITRE·05:00 PM
Data Sourced
via MITRE·05:00 PM
Description
Data Sourced
via NVD·05:29 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·05:29 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2018-15910?

CVE-2018-15910 is a vulnerability in Artifex Ghostscript before 9.24 that allows attackers to crash the interpreter or execute code by supplying crafted PostScript files.

2

Which software is affected by CVE-2018-15910?

CVE-2018-15910 affects Artifex Ghostscript versions up to and including 9.24, Debian Linux 8.0 and 9.0, Canonical Ubuntu Linux 14.04, 16.04, and 18.04, Redhat Enterprise Linux Desktop, Server, and Workstation 7.0, Redhat Enterprise Linux Server Eus 7.5, Artifex GPL Ghostscript up to 9.26, and Pulsesecure Pulse Connect Secure versions 8.2r1.0 to 8.2r12.1, 8.3r1 to 8.3r7.1, and 9.0r1 to 9.0r3.4.

3

What is the severity rating of CVE-2018-15910?

CVE-2018-15910 has a severity rating of 7.8 (high).

4

How can I fix CVE-2018-15910?

To fix CVE-2018-15910, update Artifex Ghostscript to version 9.24, Debian Linux to the recommended version, Canonical Ubuntu Linux to the recommended version, Redhat Enterprise Linux to the recommended version, Artifex GPL Ghostscript to version 9.27, and Pulsesecure Pulse Connect Secure to the recommended version.

5

Where can I find more information about CVE-2018-15910?

You can find more information about CVE-2018-15910 at the following references: [http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=c3476dde7743761a4e1d39a631716199b696b880], [https://www.kb.cert.org/vuls/id/332928], [https://bugs.ghostscript.com/show_bug.cgi?id=699656].

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203