CVE-2018-15911: High severity Debian Debian Linux vulnerability
In Artifex Ghostscript 9.23 before 2018-08-24, attackers able to supply crafted PostScript could use uninitialized memory access in the aesdecode operator to crash the interpreter or potentially execute code.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/ghostscriptto a version that resolves this vulnerability.Fixed in 9.24 - Upgrade
Upgrade
debian/ghostscriptto a version that resolves this vulnerability.Fixed in 9.53.3~dfsg-7+deb11u7Fixed in 9.53.3~dfsg-7+deb11u9Fixed in 10.0.0~dfsg-11+deb12u6Fixed in 10.04.0~dfsg-2 - Upgrade
Upgrade
alpine/ghostscriptto a version that resolves this vulnerability.Fixed in 9.24-r0
Event History
Frequently Asked Questions
What is CVE-2018-15911?
CVE-2018-15911 is a vulnerability in Artifex Ghostscript 9.23 before 2018-08-24 that allows attackers to use uninitialized memory access to crash the interpreter or potentially execute code.
How severe is CVE-2018-15911?
CVE-2018-15911 has a severity score of 7.8, indicating a high severity.
Which software versions are affected by CVE-2018-15911?
Artifex Ghostscript versions before 9.24 are affected by CVE-2018-15911.
How can I fix CVE-2018-15911?
To fix CVE-2018-15911, upgrade to Artifex Ghostscript version 9.24.
Where can I find more information about CVE-2018-15911?
More information about CVE-2018-15911 can be found at the following references: [1][2][3].