CVE-2018-16418: Buffer Overflow

Published Sep 4, 2018
·
Updated

A buffer overflow when handling string concatenation in utilacltostr in tools/util.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Affected Software

18 affected componentsFixes available
redhat/opensc<0.19.0
0.19.0
Opensc Project Opensc<=0.18.0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/opensc to a version that resolves this vulnerability.

    Fixed in 0.19.0
  2. Upgrade

    Upgrade alpine/opensc to a version that resolves this vulnerability.

    Fixed in 0.19.0-r0
  3. Upgrade

    Upgrade OpenSC to a version that resolves this vulnerability.

    Fixed in 0.19.0-rc1

Event History

Sep 4, 2018
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·12:29 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·12:29 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2018-16418?

The severity of CVE-2018-16418 is medium with a CVSS score of 6.6.

2

How does CVE-2018-16418 impact the affected software?

CVE-2018-16418 could be used by attackers to cause a denial of service (application crash) or potentially have unspecified other impacts.

3

Which software versions are affected by CVE-2018-16418?

Versions up to and including 0.18.0 of OpenSC Project OpenSC and versions up to but not including 0.19.0 of Red Hat OpenSC are affected by CVE-2018-16418.

4

How can I fix CVE-2018-16418?

To fix CVE-2018-16418, upgrade to version 0.19.0 or later of OpenSC.

5

Where can I find more information about CVE-2018-16418?

More information about CVE-2018-16418 can be found in the following references: [Red Hat Advisory](https://access.redhat.com/errata/RHSA-2019:2154), [OpenSC Commit](https://github.com/OpenSC/OpenSC/commit/360e95d45ac4123255a4c796db96337f332160ad#diff-628c8445c4e7ae92bbc4be08ba11a4c3), [OpenSC Release](https://github.com/OpenSC/OpenSC/releases/tag/0.19.0-rc1).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203