CVE-2018-16421: Buffer Overflow

Published Sep 4, 2018
·
Updated

Several buffer overflows when handling responses from a CAC Card in cacgetserialnrfromCUID in libopensc/card-cac.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Affected Software

18 affected componentsFixes available
redhat/opensc<0.19.0
0.19.0
Opensc Project Opensc<=0.18.0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0
alpine/opensc<0.19.0-r0
0.19.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/opensc to a version that resolves this vulnerability.

    Fixed in 0.19.0
  2. Upgrade

    Upgrade alpine/opensc to a version that resolves this vulnerability.

    Fixed in 0.19.0-r0
  3. Upgrade

    Upgrade OpenSC to a version that resolves this vulnerability.

    Fixed in 0.19.0-rc1

Event History

Sep 4, 2018
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Data Sourced
via NVD·12:29 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·12:29 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2018-16421?

CVE-2018-16421 is a vulnerability that allows attackers to cause a denial of service (application crash) or possibly have other unspecified impact by exploiting buffer overflows when handling responses from a CAC Card in OpenSC before version 0.19.0-rc1.

2

How severe is CVE-2018-16421?

CVE-2018-16421 has a severity score of 6.6 (medium).

3

Which software versions are affected by CVE-2018-16421?

OpenSC versions up to and including 0.18.0 and Red Hat OpenSC versions up to but excluding 0.19.0 are affected by CVE-2018-16421.

4

How can I fix CVE-2018-16421?

To fix CVE-2018-16421, update OpenSC to version 0.19.0 or later, or update Red Hat OpenSC to version 0.19.0 or later.

5

What is CWE-119?

CWE-119 is a common weakness enumeration category for buffer errors, such as buffer overflows, which is associated with CVE-2018-16421.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203