CVE-2018-18284: High severity Artifex Ghostscript vulnerability
Artifex Ghostscript 9.25 and earlier allows attackers to bypass a sandbox protection mechanism via vectors involving the 1Policy operator.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/ghostscriptto a version that resolves this vulnerability.Fixed in 9.26 - Upgrade
Upgrade
debian/ghostscriptto a version that resolves this vulnerability.Fixed in 9.53.3~dfsg-7+deb11u7Fixed in 9.53.3~dfsg-7+deb11u11Fixed in 10.0.0~dfsg-11+deb12u8Fixed in 10.05.1~dfsg-1+deb13u1Fixed in 10.06.0~dfsg-3 - Upgrade
Upgrade
alpine/ghostscriptto a version that resolves this vulnerability.Fixed in 9.25-r1
Event History
Frequently Asked Questions
What is the vulnerability ID for Artifex Ghostscript?
The vulnerability ID for Artifex Ghostscript is CVE-2018-18284.
What is the severity level of CVE-2018-18284?
The severity level of CVE-2018-18284 is high with a severity value of 8.6.
How does the vulnerability CVE-2018-18284 allow attackers to bypass a sandbox protection mechanism?
The vulnerability CVE-2018-18284 allows attackers to bypass a sandbox protection mechanism through vectors involving the 1Policy operator.
Which versions of Artifex Ghostscript are affected by CVE-2018-18284?
Artifex Ghostscript versions up to and including 9.25 are affected by CVE-2018-18284.
Where can I find more information about CVE-2018-18284?
You can find more information about CVE-2018-18284 on the following links: [link1](https://bugs.ghostscript.com/show_bug.cgi?id=699963), [link2](https://security-tracker.debian.org/tracker/CVE-2018-18284), [link3](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18284).