CVE-2018-18444: High severity Ilm OpenEXR vulnerability
Last updated 25 August 2025
Other sources
makeMultiView.cpp in exrmultiview in OpenEXR 2.3.0 has an out-of-bounds write, leading to an assertion failure or possibly unspecified other impact.
— Launchpad
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/openexrto a version that resolves this vulnerability.Fixed in 3.1.5-5Fixed in 3.1.13-2Fixed in 3.4.16+ds-1
Event History
Frequently Asked Questions
What is CVE-2018-18444?
CVE-2018-18444 is a vulnerability in OpenEXR 2.3.0 that allows an out-of-bounds write, leading to an assertion failure or other unspecified impact.
What is the severity of CVE-2018-18444?
The severity of CVE-2018-18444 is high with a CVSS score of 8.8.
How does CVE-2018-18444 affect OpenEXR?
CVE-2018-18444 affects OpenEXR 2.3.0 and possibly other versions.
How can I fix CVE-2018-18444?
To fix CVE-2018-18444, upgrade to OpenEXR version 2.4.0 or higher.
Where can I find more information about CVE-2018-18444?
You can find more information about CVE-2018-18444 at the following references: [link1](https://github.com/openexr/openexr/issues/351), [link2](https://github.com/openexr/openexr/releases/tag/v2.4.0), [link3](https://usn.ubuntu.com/4148-1/).