CVE-2018-19280: Centreon XSS Vulnerability
Centreon 3.4.x (fixed in Centreon 18.10.0) has XSS via the resource name or macro expression of a poller macro.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/centreon/centreonto a version that resolves this vulnerability.Fixed in 18.10.0 - Upgrade
Upgrade
Centreonto a version that resolves this vulnerability.Fixed in 18.10.0
Event History
Frequently Asked Questions
What is CVE-2018-19280?
CVE-2018-19280 is a vulnerability found in Centreon 3.4.x, which allows for XSS attacks through the resource name or macro expression of a poller macro.
What is the severity of CVE-2018-19280?
The severity of CVE-2018-19280 is medium, with a severity value of 6.1.
How can I fix CVE-2018-19280?
To fix CVE-2018-19280, you need to update Centreon to version 18.10.0 or higher.
Where can I find more information about CVE-2018-19280?
You can find more information about CVE-2018-19280 on the NVD website and the Centreon documentation.
What is CWE-79?
CWE-79 is a common weakness enumeration category that refers to cross-site scripting (XSS) vulnerabilities.