CVE-2018-19573: XSS
GitLab CE/EE, versions 10.3 up to 11.x before 11.3.11, 11.4 before 11.4.8, and 11.5 before 11.5.1, are vulnerable to an XSS vulnerability in Markdown fields via Mermaid.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 11.3.11 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 11.4.8 - Upgrade
Upgrade
GitLab CE/EEto a version that resolves this vulnerability.Fixed in 11.5.1
Event History
Frequently Asked Questions
What is the severity of CVE-2018-19573?
CVE-2018-19573 is classified as a medium severity XSS vulnerability.
How do I fix CVE-2018-19573?
To fix CVE-2018-19573, upgrade GitLab to version 11.3.11, 11.4.8, or 11.5.1 or later.
What versions of GitLab are affected by CVE-2018-19573?
CVE-2018-19573 affects GitLab CE/EE versions 10.3 to 11.x before 11.3.11, 11.4 before 11.4.8, and 11.5 before 11.5.1.
What type of vulnerability is CVE-2018-19573?
CVE-2018-19573 is an XSS vulnerability that occurs in Markdown fields via Mermaid.
Is CVE-2018-19573 present in both GitLab CE and EE?
Yes, CVE-2018-19573 affects both GitLab Community Edition (CE) and Enterprise Edition (EE) within the specified versions.