CVE-2018-19932: Integer Overflow

Published Dec 7, 2018
·
Updated

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils through 2.31. There is an integer overflow and infinite loop caused by the ISCONTAINEDBYLMA macro in elf.c.

Affected Software

23 affected componentsFixes available
GNU binutils<=2.31
NetApp Vasa Provider>=7.2
NetApp Cluster Data Ontap
All of the following
NetApp Vasa Provider>=7.2
NetApp Cluster Data Ontap
debian/binutils
2.35.2-22.40-22.44-3
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils<2.32-r0
2.32-r0
alpine/binutils-avr<2.32-r0
2.32-r0
alpine/binutils-avr<2.32-r0
2.32-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/binutils to a version that resolves this vulnerability.

    Fixed in 2.35.2-2Fixed in 2.40-2Fixed in 2.44-3
  2. Upgrade

    Upgrade alpine/binutils to a version that resolves this vulnerability.

    Fixed in 2.32-r0
  3. Upgrade

    Upgrade alpine/binutils-avr to a version that resolves this vulnerability.

    Fixed in 2.32-r0

Event History

Dec 7, 2018
CVE Published
via MITRE·07:00 AM
Data Sourced
via MITRE·07:00 AM
Description
Data Sourced
via OSV·07:29 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2018-19932?

CVE-2018-19932 is a vulnerability in the Binary File Descriptor (BFD) library (aka libbfd) in GNU Binutils.

2

How does the vulnerability in CVE-2018-19932 occur?

The vulnerability in CVE-2018-19932 occurs due to an integer overflow and infinite loop caused by the IS_CONTAINED_BY_LMA macro in elf.c.

3

Which software versions are affected by CVE-2018-19932?

The affected software versions include binutils 2.30-21ubuntu1~18.04.3, binutils 2.26.1-1ubuntu1~16.04.8+, and binutils up to version 2.31.1-16.

4

How can I fix CVE-2018-19932?

To fix CVE-2018-19932, it is recommended to update binutils to version 2.30-21ubuntu1~18.04.3 (for Ubuntu 18.04), binutils to version 2.26.1-1ubuntu1~16.04.8+ (for Ubuntu 16.04), or binutils to version 2.35.2-2, 2.40-2, or 2.41-5 (for Debian).

5

Where can I find more information about CVE-2018-19932?

You can find more information about CVE-2018-19932 at the following references: [1] https://sourceware.org/bugzilla/show_bug.cgi?id=23932, [2] https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=beab453223769279cc1cef68a1622ab8978641f7, [3] http://www.securityfocus.com/bid/106144.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203