CVE-2018-20174: High severity rdesktop RDesktop vulnerability
rdesktop versions up to and including v1.8.3 contain an Out-Of-Bounds Read in the function uicliphandledata() that results in an information leak.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-20174?
CVE-2018-20174 is classified as a low-severity vulnerability due to its information leak characteristics.
How do I fix CVE-2018-20174?
To fix CVE-2018-20174, upgrade rdesktop to version 1.8.6-2 or later.
What software versions are affected by CVE-2018-20174?
CVE-2018-20174 affects rdesktop versions up to and including 1.8.3.
What is the nature of the vulnerability in CVE-2018-20174?
CVE-2018-20174 is an Out-Of-Bounds Read vulnerability in the ui_clip_handle_data() function.
Is there a workaround for CVE-2018-20174?
There is no official workaround for CVE-2018-20174; upgrading the software is the recommended course of action.