CVE-2018-20175: High severity rdesktop RDesktop vulnerability
rdesktop versions up to and including v1.8.3 contains several Integer Signedness errors that lead to Out-Of-Bounds Reads in the file mcs.c and result in a Denial of Service (segfault).
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-20175?
CVE-2018-20175 is classified as a Denial of Service vulnerability leading to application crashes.
How do I fix CVE-2018-20175?
To remediate CVE-2018-20175, upgrade rdesktop to version 1.8.6-2 or later.
Which versions of rdesktop are affected by CVE-2018-20175?
rdesktop versions up to and including v1.8.3 are affected by CVE-2018-20175.
What are the potential impacts of CVE-2018-20175?
The exploit of CVE-2018-20175 can lead to out-of-bounds reads, resulting in application crashes.
Is there a way to mitigate CVE-2018-20175 if I cannot upgrade?
If upgrading is not possible for CVE-2018-20175, consider implementing network security measures to limit exposure.