CVE-2018-20176: High severity rdesktop RDesktop vulnerability
rdesktop versions up to and including v1.8.3 contain several Out-Of- Bounds Reads in the file secure.c that result in a Denial of Service (segfault).
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-20176?
CVE-2018-20176 is considered a critical vulnerability due to its potential to cause Denial of Service via Out-Of-Bounds Reads.
How do I fix CVE-2018-20176?
To fix CVE-2018-20176, update rdesktop to versions 1.8.6-2 or 1.9.0-2 or later.
What versions of rdesktop are affected by CVE-2018-20176?
All rdesktop versions up to and including v1.8.3 are affected by CVE-2018-20176.
What type of vulnerability is CVE-2018-20176?
CVE-2018-20176 is classified as an Out-Of-Bounds Read vulnerability.
Can CVE-2018-20176 lead to data leakage?
While CVE-2018-20176 primarily results in a Denial of Service, Out-Of-Bounds Reads can potentially lead to information disclosure in certain scenarios.