CVE-2018-20177: Buffer Overflow
rdesktop versions up to and including v1.8.3 contain an Integer Overflow that leads to a Heap-Based Buffer Overflow in the function rdpinunistr() and results in memory corruption and possibly even a remote code execution.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-20177?
CVE-2018-20177 is considered a high severity vulnerability due to the potential for remote code execution.
How do I fix CVE-2018-20177?
To fix CVE-2018-20177, update to rdesktop version 1.8.6-2 or 1.9.0-2 or later.
Which versions of rdesktop are affected by CVE-2018-20177?
All versions of rdesktop up to and including v1.8.3 are affected by CVE-2018-20177.
What type of vulnerability is CVE-2018-20177?
CVE-2018-20177 is an integer overflow vulnerability that leads to a heap-based buffer overflow.
Can CVE-2018-20177 lead to memory corruption?
Yes, CVE-2018-20177 can lead to memory corruption and possibly allow for remote code execution.