CVE-2018-20178: High severity rdesktop RDesktop vulnerability
rdesktop versions up to and including v1.8.3 contain an Out-Of-Bounds Read in the function processdemandactive() that results in a Denial of Service (segfault).
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-20178?
CVE-2018-20178 is classified as a Denial of Service vulnerability due to an Out-Of-Bounds Read that can lead to a segfault.
How do I fix CVE-2018-20178?
To fix CVE-2018-20178, update rdesktop to version 1.8.6-2 or 1.9.0-2 or later.
Which versions of rdesktop are affected by CVE-2018-20178?
CVE-2018-20178 affects rdesktop versions up to and including 1.8.3.
What is the impact of CVE-2018-20178?
The impact of CVE-2018-20178 is a Denial of Service, where the service can crash due to a segfault.
Is CVE-2018-20178 specific to any operating systems?
CVE-2018-20178 specifically affects Debian Linux versions 8.0 and 9.0 when using vulnerable rdesktop versions.