CVE-2018-20179: Integer Underflow
rdesktop versions up to and including v1.8.3 contain an Integer Underflow that leads to a Heap-Based Buffer Overflow in the function lspciprocess() and results in memory corruption and probably even a remote code execution.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-20179?
CVE-2018-20179 has a high severity rating due to its potential for remote code execution and memory corruption.
How do I fix CVE-2018-20179?
To fix CVE-2018-20179, upgrade rdesktop to version 1.8.6-2 or later, or 1.9.0-2 or later if applicable.
Which versions of rdesktop are affected by CVE-2018-20179?
CVE-2018-20179 affects all versions of rdesktop up to and including version 1.8.3.
Can CVE-2018-20179 lead to data theft?
Yes, CVE-2018-20179 could potentially allow attackers to gain access to sensitive data through remote code execution.
Is CVE-2018-20179 a local or remote vulnerability?
CVE-2018-20179 is a remote vulnerability, enabling attackers to exploit the system without local access.