CVE-2018-20180: Buffer Overflow
rdesktop versions up to and including v1.8.3 contain an Integer Underflow that leads to a Heap-Based Buffer Overflow in the function rdpsnddbgprocess() and results in memory corruption and probably even a remote code execution.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-20180?
CVE-2018-20180 is considered a high-severity vulnerability due to its potential for remote code execution.
How does CVE-2018-20180 affect rdesktop versions?
CVE-2018-20180 affects rdesktop versions up to and including v1.8.3, allowing for memory corruption through a heap-based buffer overflow.
How do I fix CVE-2018-20180?
To fix CVE-2018-20180, upgrade rdesktop to version 1.8.6-2 or later.
What type of vulnerability is CVE-2018-20180?
CVE-2018-20180 is classified as an Integer Underflow leading to a Heap-Based Buffer Overflow.
Can CVE-2018-20180 lead to system compromise?
Yes, CVE-2018-20180 can lead to memory corruption and potentially allow remote code execution.