CVE-2018-20182: Buffer Overflow
rdesktop versions up to and including v1.8.3 contain a Buffer Overflow over the global variables in the function seamlessprocessline() that results in memory corruption and probably even a remote code execution.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-20182?
CVE-2018-20182 has a high severity level due to the potential for memory corruption and remote code execution.
How do I fix CVE-2018-20182?
To fix CVE-2018-20182, upgrade rdesktop to version 1.8.6-2 or later.
Which versions of rdesktop are affected by CVE-2018-20182?
rdesktop versions up to and including 1.8.3 are affected by CVE-2018-20182.
What type of vulnerability is CVE-2018-20182?
CVE-2018-20182 is a buffer overflow vulnerability that can lead to memory corruption.
Can CVE-2018-20182 be exploited remotely?
Yes, CVE-2018-20182 can potentially be exploited remotely, allowing for code execution.