CVE-2018-20856: Use After Free
A flaw was found in the Linux kernel’s block driver implementation (blkdrainqueue() function) where a use-after-free condition could be triggered while draining the outstanding command queue in the systems block device subsystem. An attacker could use this flaw to crash the system or corrupt local memory, which may lead to privilege escalation.
Other sources
A flaw was found in the Linux kernels block driver implementation where a use-after-free condition could be triggered while draining the outstanding command queue in the systems block device subsystem.
A patient local attacker can use this flaw to corrupt memory, possibly crashing the system and possibly leading to privilege escalation.
https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.18.7 https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=54648cf1ec2d7f4b6a71767799c45676a138ca24 https://github.com/torvalds/linux/commit/54648cf1ec2d7f4b6a71767799c45676a138ca24
— Red Hat
An issue was discovered in the Linux kernel before 4.18.7. In block/blk-core.c, there is an blkdrainqueue() use-after-free because a certain error case is mishandled.
— Ubuntu
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:3.10.0-1062.4.1.rt56.1027.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-1062.4.1.el7 - Upgrade
Upgrade
redhat/kernel-altto a version that resolves this vulnerability.Fixed in 0:4.14.0-115.14.1.el7a - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-693.62.1.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-862.48.1.el7 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:3.10.0-957.46.1.el7 - Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 1:3.10.0-693.62.1.rt56.659.el6 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2018-20856?
CVE-2018-20856 is rated as high severity due to its potential to cause denial of service or data corruption.
How do I fix CVE-2018-20856?
To fix CVE-2018-20856, update the Linux kernel to a version that addresses this vulnerability.
What systems are affected by CVE-2018-20856?
CVE-2018-20856 affects various versions of the Linux kernel, including specific Red Hat and Debian packages.
Can CVE-2018-20856 be exploited remotely?
Yes, an attacker with access to the block device subsystem could potentially exploit CVE-2018-20856.
What are the potential consequences of CVE-2018-20856?
Exploitation of CVE-2018-20856 can lead to system crashes and possible corruption of local data.