CVE-2018-5750: Infoleak
The acpismbushcadd function in drivers/acpi/sbshc.c in the Linux kernel through 4.14.15 allows local users to obtain sensitive address information by reading dmesg data from an SBS HC printk call.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1
Event History
Frequently Asked Questions
What is the severity of CVE-2018-5750?
CVE-2018-5750 has a medium severity rating, indicating a potential security risk if exploited.
How do I fix CVE-2018-5750?
To resolve CVE-2018-5750, users should update their Linux kernel to version 4.14.16 or higher.
Who is affected by CVE-2018-5750?
CVE-2018-5750 affects local users on systems running vulnerable versions of the Linux kernel up to 4.14.15.
What type of vulnerability is CVE-2018-5750?
CVE-2018-5750 is a local information disclosure vulnerability that allows unauthorized access to sensitive data.
Which Linux distributions are affected by CVE-2018-5750?
CVE-2018-5750 impacts various distributions including Debian and Ubuntu, especially those using Linux kernel versions up to 4.14.15.