CVE-2018-6927: Integer Overflow

Published Feb 12, 2018
·
Updated

The futexrequeue function in kernel/futex.c in the Linux kernel before 4.14.15 might allow attackers to cause a denial of service (integer overflow) or possibly have unspecified other impact by triggering a negative wake or requeue value.

Affected Software

17 affected componentsFixes available
redhat/kernel<4.14.15
4.14.15
Linux Linux kernel<4.14.15
Canonical Ubuntu Linux=12.04
Canonical Ubuntu Linux=14.04
Canonical Ubuntu Linux=16.04
Canonical Ubuntu Linux=17.10
Debian Debian Linux=7.0
Debian Debian Linux=8.0
redhat Virtualization Host=4.0
redhat Enterprise Linux Desktop=7.0
redhat Enterprise Linux Server=7.0
redhat Enterprise Linux Server Aus=7.6
redhat Enterprise Linux Server Eus=7.6
redhat Enterprise Linux Server Tus=7.6
redhat Enterprise Linux Workstation=7.0
Google Android
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/kernel to a version that resolves this vulnerability.

    Fixed in 4.14.15
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1
  3. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Fixed in 4.14.15

Event History

Feb 12, 2018
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·07:00 PM
Data Sourced
via MITRE·07:00 PM
Description
Data Sourced
via NVD·07:29 PM
RemedyDescriptionSeverityWeaknessAffected Software
Jul 2, 2018
Data Sourced
via Android·12:00 AM
SeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2018-6927?

The severity of CVE-2018-6927 is significant as it can lead to denial of service or potentially other impacts.

2

How do I fix CVE-2018-6927?

To fix CVE-2018-6927, ensure that your Linux kernel version is upgraded to at least 4.14.15 or a later version.

3

Which systems are affected by CVE-2018-6927?

CVE-2018-6927 affects multiple systems including certain versions of Debian, Ubuntu, and Red Hat Enterprise Linux.

4

Can CVE-2018-6927 lead to exploits?

Yes, CVE-2018-6927 can be exploited by attackers to cause denial of service due to integer overflow vulnerabilities.

5

Is CVE-2018-6927 present in the latest Linux kernel versions?

CVE-2018-6927 is not present in Linux kernel versions that are newer than 4.14.15.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203