CVE-2018-7162: Denial of Service Vulnerability in TLS

Published Jun 12, 2018
·
Updated

All versions of 9.x and later are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node process which provides an http server supporting TLS server to crash. This can be accomplished by sending duplicate/unexpected messages during the handshake. This vulnerability has been addressed by updating the TLS implementation. Thanks to Jordan Zebor at F5 Networks all of his help investigating this issue with the Node.js team.

Other sources

All versions of Node.js 9.x and 10.x are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node process which provides an http server supporting TLS server to crash. This can be accomplished by sending duplicate/unexpected messages during the handshake. This vulnerability has been addressed by updating the TLS implementation.

Affected Software

5 affected componentsFixes available
Nodejs Node.js>=9.0.0<9.11.2
Nodejs Node.js>=10.0.0<10.4.1
Node.js Node.js>=9.0.0<9.11.2, >=10.0.0<10.4.1
9.11.210.4.1
Node.js Node.js>=10.0.0<10.4.1
10.4.1
Node.js Node.js>=9.0.0<9.11.2
9.11.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 9.11.2Fixed in 10.4.1
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 10.4.1
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 9.11.2

Event History

Jun 12, 2018
CVE Published
via Node.js·11:00 PM
Data Sourced
via Node.js·11:00 PM
DescriptionSeverity
Data Sourced
via Node.js·11:51 PM
Affected Software
Jun 13, 2018
CVE Published
via MITRE·04:00 PM
Data Sourced
via MITRE·04:00 PM
DescriptionWeakness
Data Sourced
via NVD·04:29 PM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2018-7162?

The severity of CVE-2018-7162 is rated as HIGH.

2

How do I fix CVE-2018-7162?

To fix CVE-2018-7162, upgrade Node.js to version 9.11.2 or later, or version 10.4.1 or later.

3

What versions of Node.js are affected by CVE-2018-7162?

CVE-2018-7162 affects all versions of Node.js from 9.0.0 to 9.11.2 and 10.0.0 to 10.4.1.

4

What type of attack does CVE-2018-7162 allow?

CVE-2018-7162 allows an attacker to execute a denial of service (DoS) attack.

5

What can an attacker send to exploit CVE-2018-7162?

An attacker can exploit CVE-2018-7162 by sending duplicate or unexpected messages during the TLS handshake.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203