CVE-2018-7322: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-dcm.c had an infinite loop that was addressed by checking for integer wraparound.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7322?
CVE-2018-7322 has been classified as a moderate severity vulnerability.
How do I fix CVE-2018-7322?
To fix CVE-2018-7322, upgrade Wireshark to version 2.4.5 or later, or to version 2.2.13 or later.
What are the affected versions in CVE-2018-7322?
CVE-2018-7322 affects Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12.
What kind of vulnerability is CVE-2018-7322?
CVE-2018-7322 is a denial-of-service vulnerability due to an infinite loop in Wireshark.
Is CVE-2018-7322 present in Debian Linux distributions?
Yes, CVE-2018-7322 is present in the Debian Linux distributions 7.0 and 8.0 that include the affected versions of Wireshark.