CVE-2018-7323: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-wccp.c had a large loop that was addressed by ensuring that a calculated length was monotonically increasing.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7323?
CVE-2018-7323 is classified as a medium severity vulnerability due to its potential to cause denial of service.
How do I fix CVE-2018-7323?
To fix CVE-2018-7323, upgrade Wireshark to the latest version, specifically version 2.4.5 or later.
What versions of Wireshark are affected by CVE-2018-7323?
CVE-2018-7323 affects Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12.
Can CVE-2018-7323 be exploited remotely?
CVE-2018-7323 could potentially be exploited remotely if a malicious packet is sent to a vulnerable Wireshark version.
What is the nature of the vulnerability in CVE-2018-7323?
CVE-2018-7323 involves a large loop in the WCCP dissector that could lead to excessive resource consumption.