CVE-2018-7324: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-sccp.c had an infinite loop that was addressed by using a correct integer data type.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7324?
CVE-2018-7324 has a moderate severity rating due to the potential for denial of service.
How do I fix CVE-2018-7324?
To fix CVE-2018-7324, you should upgrade Wireshark to version 2.4.5 or later.
What versions of Wireshark are affected by CVE-2018-7324?
CVE-2018-7324 affects Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12.
Does CVE-2018-7324 affect Debian Linux?
Yes, CVE-2018-7324 affects Debian Linux 7.0 and 8.0 if they have the vulnerable versions of Wireshark installed.
What type of vulnerability is CVE-2018-7324 categorized as?
CVE-2018-7324 is categorized as an infinite loop vulnerability within the Wireshark dissector.