CVE-2018-7326: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-lltd.c had an infinite loop that was addressed by using a correct integer data type.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7326?
CVE-2018-7326 is considered a moderate severity vulnerability due to its potential to cause an infinite loop in Wireshark.
How do I fix CVE-2018-7326?
To fix CVE-2018-7326, update Wireshark to version 2.4.5 or later for the 2.4.x series and version 2.2.13 or later for the 2.2.x series.
Which versions of Wireshark are affected by CVE-2018-7326?
Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12 are affected by CVE-2018-7326.
What type of vulnerability is CVE-2018-7326?
CVE-2018-7326 is a logic flaw vulnerability that leads to an infinite loop during packet dissection.
Who is impacted by CVE-2018-7326?
Users of Wireshark versions specified in CVE-2018-7326 are impacted, particularly those analyzing network traffic.