CVE-2018-7327: High severity Wireshark Wireshark vulnerability

Published Feb 23, 2018
·
Updated

In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-openflowv6.c had an infinite loop that was addressed by validating property lengths.

Affected Software

21 affected componentsFixes available
Wireshark Wireshark>=2.2.0<=2.2.12
Wireshark Wireshark>=2.4.0<=2.4.4
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.2.15-r0
2.2.15-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0
alpine/wireshark>=2.2.0<2.4.5-r0
2.4.5-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/wireshark to a version that resolves this vulnerability.

    Fixed in 2.4.5-r0
  2. Upgrade

    Upgrade alpine/wireshark to a version that resolves this vulnerability.

    Fixed in 2.2.15-r0

Event History

Feb 23, 2018
CVE Published
via MITRE·10:00 PM
Data Sourced
via MITRE·10:00 PM
Description
Data Sourced
via NVD·10:29 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·10:29 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2018-7327?

CVE-2018-7327 is categorized as a high severity vulnerability due to the potential for denial of service through an infinite loop.

2

How do I fix CVE-2018-7327?

To fix CVE-2018-7327, upgrade Wireshark to version 2.4.5 or later, or 2.2.13 or later.

3

What versions of Wireshark are affected by CVE-2018-7327?

CVE-2018-7327 affects Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12.

4

What type of vulnerability is CVE-2018-7327?

CVE-2018-7327 is a denial of service vulnerability caused by an infinite loop.

5

Is CVE-2018-7327 being actively exploited?

There have been no public reports of CVE-2018-7327 being actively exploited in the wild.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203