CVE-2018-7328: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-usb.c had an infinite loop that was addressed by rejecting short frame header lengths.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7328?
CVE-2018-7328 is considered a medium severity vulnerability due to its potential to cause denial of service.
How do I fix CVE-2018-7328?
To fix CVE-2018-7328, update Wireshark to version 2.4.5 or later, or to version 2.2.13 or later.
What versions of Wireshark are affected by CVE-2018-7328?
CVE-2018-7328 affects Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12.
What does CVE-2018-7328 exploit in Wireshark?
CVE-2018-7328 exploits an infinite loop in the USB dissector caused by short frame header lengths.
Can CVE-2018-7328 lead to data loss?
CVE-2018-7328 is primarily a denial-of-service vulnerability and is not directly associated with data loss.