CVE-2018-7329: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-s7comm.c had an infinite loop that was addressed by correcting off-by-one errors.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7329?
CVE-2018-7329 has been classified as a medium severity vulnerability.
How do I fix CVE-2018-7329?
To fix CVE-2018-7329, update Wireshark to version 2.4.5 or later, or 2.2.13 or later.
What software versions are affected by CVE-2018-7329?
CVE-2018-7329 affects Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12.
What type of vulnerability is CVE-2018-7329?
CVE-2018-7329 is a vulnerability that involves an infinite loop caused by off-by-one errors.
Is there a workaround for CVE-2018-7329 if I cannot update?
There are no known workarounds for CVE-2018-7329, so updating is the recommended action.