CVE-2018-7330: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-thread.c had an infinite loop that was addressed by using a correct integer data type.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7330?
CVE-2018-7330 is considered a medium severity vulnerability due to its potential to cause an infinite loop.
How do I fix CVE-2018-7330?
To fix CVE-2018-7330, update Wireshark to versions 2.4.5 or later, or to version 2.2.13 or later.
What software versions are affected by CVE-2018-7330?
CVE-2018-7330 affects Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12.
What type of issue is associated with CVE-2018-7330?
CVE-2018-7330 is associated with an infinite loop vulnerability in the Wireshark dissector code.
Is CVE-2018-7330 remotely exploitable?
CVE-2018-7330 is not remotely exploitable but may affect local users processing certain packet captures.