CVE-2018-7331: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-ber.c had an infinite loop that was addressed by validating a length.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7331?
CVE-2018-7331 is classified as a medium severity vulnerability due to its potential to cause an infinite loop in the Wireshark application.
How do I fix CVE-2018-7331?
To fix CVE-2018-7331, update Wireshark to version 2.4.5 or 2.2.13 or later, where the issue has been addressed.
Which versions of Wireshark are affected by CVE-2018-7331?
CVE-2018-7331 affects Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12.
Does CVE-2018-7331 affect Debian users?
Yes, CVE-2018-7331 can affect Debian GNU/Linux 8.0 users running the vulnerable versions of Wireshark.
What type of vulnerability is CVE-2018-7331?
CVE-2018-7331 is a denial of service vulnerability that occurs due to an infinite loop caused by improper validation of packet length.