CVE-2018-7332: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12, epan/dissectors/packet-reload.c had an infinite loop that was addressed by validating a length.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7332?
CVE-2018-7332 has a medium severity rating due to its potential to cause denial of service through an infinite loop.
How do I fix CVE-2018-7332?
To fix CVE-2018-7332, upgrade Wireshark to version 2.4.5 or 2.2.13 or later.
Which versions of Wireshark are affected by CVE-2018-7332?
CVE-2018-7332 affects Wireshark versions 2.4.0 to 2.4.4 and 2.2.0 to 2.2.12.
Does CVE-2018-7332 affect Debian systems?
Yes, CVE-2018-7332 affects Debian GNU/Linux version 7.0 when Wireshark versions within the vulnerable ranges are installed.
Is there a workaround for CVE-2018-7332?
There are no known workarounds for CVE-2018-7332; the recommended action is to update the software.