CVE-2018-7417: High severity Wireshark Wireshark vulnerability
In Wireshark 2.2.0 to 2.2.12 and 2.4.0 to 2.4.4, the IPMI dissector could crash. This was addressed in epan/dissectors/packet-ipmi-picmg.c by adding support for crafted packets that lack an IPMI header.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7417?
CVE-2018-7417 has a severity rating of medium, as it could allow crafted packets to crash Wireshark.
How do I fix CVE-2018-7417?
To fix CVE-2018-7417, users should upgrade Wireshark to a version later than 2.2.12 or 2.4.4.
Which versions of Wireshark are affected by CVE-2018-7417?
CVE-2018-7417 affects Wireshark versions 2.2.0 to 2.2.12 and 2.4.0 to 2.4.4.
What type of attack does CVE-2018-7417 involve?
CVE-2018-7417 involves a denial-of-service attack where the IPMI dissector can crash due to crafted packets.
Is CVE-2018-7417 related to Linux distributions?
Yes, CVE-2018-7417 impacts Debian GNU/Linux versions 7.0 and 8.0 when running vulnerable Wireshark versions.