CVE-2018-7420: High severity Wireshark Wireshark vulnerability
In Wireshark 2.2.0 to 2.2.12 and 2.4.0 to 2.4.4, the pcapng file parser could crash. This was addressed in wiretap/pcapng.c by adding a block-size check for sysdig event blocks.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.5-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.15-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-7420?
CVE-2018-7420 has been classified with moderate severity due to its potential to crash the application.
How do I fix CVE-2018-7420?
To fix CVE-2018-7420, update Wireshark to a version that is not affected, specifically 2.2.13 or 2.4.5 and later.
Which versions of Wireshark are impacted by CVE-2018-7420?
CVE-2018-7420 affects Wireshark versions 2.2.0 to 2.2.12 and 2.4.0 to 2.4.4.
What type of vulnerability is CVE-2018-7420?
CVE-2018-7420 is a denial-of-service vulnerability due to flaws in the pcapng file parser.
Does CVE-2018-7420 affect any operating systems?
Yes, CVE-2018-7420 affects Debian GNU/Linux versions 7.0 and 8.0 when using the vulnerable Wireshark versions.