CVE-2018-8791: High severity rdesktop RDesktop vulnerability
rdesktop versions up to and including v1.8.3 contain an Out-Of-Bounds Read in function rdpdrprocess() that results in an information leak.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-8791?
CVE-2018-8791 is categorized as a medium severity vulnerability due to its potential for information leakage.
How do I fix CVE-2018-8791?
To fix CVE-2018-8791, update rdesktop to version 1.8.6-2 or later.
Which versions of rdesktop are affected by CVE-2018-8791?
rdesktop versions up to and including 1.8.3 are affected by CVE-2018-8791.
What type of vulnerability is CVE-2018-8791?
CVE-2018-8791 is an Out-Of-Bounds Read vulnerability that results in an information leak.
What platforms are impacted by CVE-2018-8791?
CVE-2018-8791 affects Debian Linux versions 8.0 and 9.0 running vulnerable rdesktop versions.