CVE-2018-8792: High severity rdesktop RDesktop vulnerability
rdesktop versions up to and including v1.8.3 contain an Out-Of-Bounds Read in function csspreadtsrequest() that results in a Denial of Service (segfault).
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-8792?
CVE-2018-8792 has been classified as a Denial of Service vulnerability.
How do I fix CVE-2018-8792?
To fix CVE-2018-8792, upgrade rdesktop to version 1.8.6-2 or later.
What versions of rdesktop are affected by CVE-2018-8792?
Versions of rdesktop up to and including 1.8.3 are affected by CVE-2018-8792.
What is the impact of CVE-2018-8792?
The impact of CVE-2018-8792 is a potential Denial of Service due to an Out-Of-Bounds Read causing a segmentation fault.
On which platforms does CVE-2018-8792 affect rdesktop?
CVE-2018-8792 affects rdesktop on Debian versions 8.0 and 9.0.