CVE-2018-8793: Buffer Overflow
rdesktop versions up to and including v1.8.3 contain a Heap-Based Buffer Overflow in function csspreadtsrequest() that results in a memory corruption and probably even a remote code execution.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-8793?
CVE-2018-8793 is classified as a high severity vulnerability due to the potential for remote code execution.
How do I fix CVE-2018-8793?
To fix CVE-2018-8793, upgrade rdesktop to versions 1.8.6-2 or 1.9.0-2.
Which versions of rdesktop are affected by CVE-2018-8793?
rdesktop versions up to and including 1.8.3 are affected by CVE-2018-8793.
Can CVE-2018-8793 lead to memory corruption?
Yes, CVE-2018-8793 can result in memory corruption due to a heap-based buffer overflow.
Is CVE-2018-8793 specific to any operating system?
CVE-2018-8793 affects multiple operating systems including Debian and openSUSE.