CVE-2018-8799: High severity rdesktop RDesktop vulnerability
rdesktop versions up to and including v1.8.3 contain an Out-Of-Bounds Read in function processsecondaryorder() that results in a Denial of Service (segfault).
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-2Fixed in 1.9.0-2 - Upgrade
Upgrade
alpine/rdesktopto a version that resolves this vulnerability.Fixed in 1.8.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2018-8799?
CVE-2018-8799 has been classified as a Denial of Service vulnerability due to its potential to cause a segmentation fault.
How do I fix CVE-2018-8799?
To fix CVE-2018-8799, upgrade rdesktop to version 1.8.6-2 or 1.9.0-2.
Which versions of rdesktop are affected by CVE-2018-8799?
CVE-2018-8799 affects rdesktop versions up to and including 1.8.3.
What impact does CVE-2018-8799 have on system performance?
CVE-2018-8799 can lead to a Denial of Service, causing the rdesktop application to crash.
Is CVE-2018-8799 specific to any operating system?
CVE-2018-8799 is relevant to rdesktop running on Debian Linux versions 8.0 and 9.0.