CVE-2019-10191: Input Validation
A vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows remote attackers to downgrade DNSSEC-secure domains to DNSSEC-insecure state, opening possibility of domain hijack using attacks against insecure DNS protocol.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/knot-resolverto a version that resolves this vulnerability.Fixed in 5.3.1-1+deb11u1Fixed in 5.6.0-1+deb12u1Fixed in 5.7.4-2 - Upgrade
Upgrade
alpine/knot-resolverto a version that resolves this vulnerability.Fixed in 4.1.0-r0 - Upgrade
Upgrade
Knot Resolverto a version that resolves this vulnerability.Fixed in 4.1.0
Event History
Frequently Asked Questions
What is CVE-2019-10191?
CVE-2019-10191 is a vulnerability discovered in DNS resolver of Knot Resolver before version 4.1.0.
How does CVE-2019-10191 affect systems?
CVE-2019-10191 allows remote attackers to downgrade DNSSEC-secure domains to DNSSEC-insecure state, opening the possibility of domain hijack using attacks against insecure DNS protocol.
What is the severity of CVE-2019-10191?
CVE-2019-10191 has a severity rating of 7.5 (high).
Which software versions are affected by CVE-2019-10191?
Knot Resolver versions before 4.1.0, Fedora 29, and Fedora 30 are affected by CVE-2019-10191.
How can I fix CVE-2019-10191?
To fix CVE-2019-10191, update Knot Resolver to version 4.1.0 or later, or upgrade to a non-vulnerable version of Fedora.