CVE-2019-10206: Input Validation
ansible-playbook -k and ansible cli tools prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
Other sources
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/ansible-engineto a version that resolves this vulnerability.Fixed in 2.8.4 - Upgrade
Upgrade
redhat/ansible-engineto a version that resolves this vulnerability.Fixed in 2.7.13 - Upgrade
Upgrade
redhat/ansible-engineto a version that resolves this vulnerability.Fixed in 2.6.19 - Upgrade
Upgrade
pip/ansibleto a version that resolves this vulnerability.Fixed in 2.6.19 - Upgrade
Upgrade
pip/ansibleto a version that resolves this vulnerability.Fixed in 2.7.13 - Upgrade
Upgrade
pip/ansibleto a version that resolves this vulnerability.Fixed in 2.8.4 - Upgrade
Upgrade
debian/ansibleto a version that resolves this vulnerability.Fixed in 2.10.7+merged+base+2.10.17+dfsg-0+deb11u1Fixed in 2.10.7+merged+base+2.10.17+dfsg-0+deb11u2Fixed in 7.7.0+dfsg-3+deb12u1Fixed in 11.2.0+dfsg-1 - Upgrade
Upgrade
alpine/ansibleto a version that resolves this vulnerability.Fixed in 2.8.4-r0 - Upgrade
Upgrade
alpine/ansibleto a version that resolves this vulnerability.Fixed in 2.4.6.0-r1 - Upgrade
Upgrade
alpine/ansibleto a version that resolves this vulnerability.Fixed in 2.6.19-r0 - Upgrade
Upgrade
alpine/ansibleto a version that resolves this vulnerability.Fixed in 2.7.13-r0 - Upgrade
Upgrade
alpine/ansible-baseto a version that resolves this vulnerability.Fixed in 2.8.4-r0 - Upgrade
Upgrade
Ansibleto a version that resolves this vulnerability.Fixed in 2.8.4 - Upgrade
Upgrade
Ansibleto a version that resolves this vulnerability.Fixed in 2.7.13 - Upgrade
Upgrade
Ansibleto a version that resolves this vulnerability.Fixed in 2.6.19
Event History
Frequently Asked Questions
What is CVE-2019-10206?
CVE-2019-10206 is a vulnerability in ansible-playbook and ansible cli tools that prompt passwords by expanding them from templates, which could expose special characters and sensitive information.
How does CVE-2019-10206 affect Ansible?
CVE-2019-10206 affects Ansible versions 2.8.x before 2.8.4, 2.7.x before 2.7.13, and 2.6.x before 2.6.19. Passwords wrapped in templates could be triggered and exposed due to expansion.
What is the severity of CVE-2019-10206?
CVE-2019-10206 has a severity level of medium.
How can I fix CVE-2019-10206 for Ansible?
To fix CVE-2019-10206, update Ansible to version 2.8.4 for 2.8.x, version 2.7.13 for 2.7.x, and version 2.6.19 for 2.6.x.
Where can I find more information about CVE-2019-10206?
You can find more information about CVE-2019-10206 on the GitHub pull requests: [GitHub Pull Request 1](https://github.com/ansible/ansible/pull/59246), [GitHub Pull Request 2](https://github.com/ansible/ansible/pull/59552), [GitHub Pull Request 3](https://github.com/ansible/ansible/pull/59553).